Misc and Backup

Home Forums Logical Invest Forum Misc and Backup

This topic contains 103 replies, has 21 voices, and was last updated by  Vangelis 1 year ago.

Viewing 15 posts - 76 through 90 (of 104 total)
  • Author
    Posts
  • #42970

    Charlie Moore
    Participant

    Hi,
    I wanted to make sure I’m not doing something wrong with these settings, since I’m new to QT and still in the 30 day trial period. I’m running version 323S and when I set trading delay = 1, none of the meta strategies seem to work. Although, even non-meta strategies do some weird things.

    For instance, set trading delay=1, restart QT, then select Nasdaq 100 hedged. My Summary window does not calculate a portfolio CAGR, Sharpe, or volatility. They show NaN. If I select GLD-USD strategy, then my summary shows a CAGR, but Sharpe and Volatility show NaN.

    Any more info I can provide to help troubleshoot?

    #43196

    Frank Grossmann
    Participant

    Yes, this is a bug. I will work on this for the next version. You can set the trading delay also in the “advanced” parameter tab of the single strategies. This one works. Here you can also set a different ranking day if you want.
    Thank you for reporting this error!

    #43368

    Charlie Moore
    Participant

    Hi,
    I was trying to use the Intraday prices option but I can’t seem to see the prices updating. I was wondering if it has to do with the data provider. I have selected Use End Of Day Data and Intraday Prices, with Tiingo as the Historical Data Provider.

    With these 2 selections, I Show Stock Data for SPY. I was expecting to see intraday prices show up here.

    Am I using this correctly?

    #43767

    Frank Grossmann
    Participant

    You only get intraday prices 15 minutes after the US stock market opened. This because of the 15 min delayed data. You will see that you use intraday data if the last date on your chart is the actual date.

    #43837

    Charlie Moore
    Participant

    OK, I must be doing something wrong if you are seeing updated prices. It is now 1pm ET on 7/14/2017 and I have waited 20 min since starting and I only see prices for 7/13/2017. As before, here are the steps I go through:
    1. Login
    2. Select ‘Use End of Day Data and Intraday Prices’, Tiingo as the Historical Data Provider, click Start.
    3. Because this was the first time today starting QT, there was historical data to update from the FTP server. I selected to update the historical data.
    4. Once QT starts, I wait 15 min.
    5. In the backtest window, I select BRS strategy.
    6. Set Show Stock Data to SPY.
    7. Click Show.

    The window that pops up only has data up to 7/13/2017, which shows as the first line.

    I am running version 4.01S. Let me know if there is more info I can provide. Thanks for your help.

    #44058

    Charlie Moore
    Participant

    Apologies for reposting, but I thought this might deserve it’s own topic instead of being buried within another topic. I originally thought this might be related to Yahoo data issue. But perhaps not.

    OK, I must be doing something wrong if others are seeing updated prices. It is now 1pm ET on 7/14/2017 and I have waited 20 min since starting and I only see prices for 7/13/2017. Here are the steps I go through:
    1. Login
    2. Select ‘Use End of Day Data and Intraday Prices’, Tiingo as the Historical Data Provider, click Start.
    3. Because this was the first time today starting QT, there was historical data to update from the FTP server. I selected to update the historical data.
    4. Once QT starts, I wait 15 min.
    5. In the backtest window, I select BRS strategy.
    6. Set Show Stock Data to SPY.
    7. Click Show.

    The window that pops up only has data up to 7/13/2017, which shows as the first line.

    I am running version 4.01S. Let me know if there is more info I can provide. Thanks for your help.

    #44069

    Frank Grossmann
    Participant

    You are right. This is a bug which came with the implementation of the new Tiingo stock price feed. I will fix this with the next version. Thank you for reporting this.

    Regards Frank

    #44079

    Charlie Moore
    Participant

    OK, thanks. I wasn’t sure if I was doing something wrong or not.

    #44659

    Alexander Horn
    Keymaster

    Hi Charlie,

    please try version 500, which has further options. A fresh data download for the standard portfolio takes no more than 5 minutes.

    #44660

    Alexander Horn
    Keymaster
    #44661

    Alexander Horn
    Keymaster

    The new QT version 500 now includes the signal consolidation, e.g. calculation of shares to rebalance: https://dl.dropboxusercontent.com/u/43364046/Logical-Invest%20QuantTrader%20versions/QuantTrader500S.zip

    #44662

    Alexander Horn
    Keymaster

    Thanks for the hint, Tom, will give it a try.

    #44978

    Charlie Moore
    Participant

    Hi,
    I have 2 separate folders of QuantTrader running at the same time so that I can play with ideas and compare the effects between the 2 running instances. Many times I will start with the exact same portfolio in both instances so that I am sure to have a good baseline before I make changes.

    I was doing exactly this, setting my baseline in 2 running instances, and using the Nasdaq 100 hedged portfolio in each instance. I noticed something that I can’t explain and would appreciate others ideas on how to correct this. As you may know, Nasdaq 100 hedged is a meta strategy using Nasdaq 100 and TMF. The underlying Nasdaq 100 and TMF in both instances appear to be exactly the same when I look in the Summary area. The strategy parameters are the same between both instances and Advanced parameters are completely blank in both instances. However, the allocation between Nasdaq 100 and TMF are different in each running instance. You can see this by looking at the historical allocation and very noticeable in the Allocations as of today. Instance A shows 70/30 split Nasdaq 100/TMF and instance B shows 0/100 Nasdaq 100/TMF.

    I am assuming the data is the same since the historical summaries are the same. I deleted all of the portfolio calculations (#xxxxx.csv files) before starting each instance so that QT would recalculate returns. Again, since the historical summaries are the same I’m assuming the returns are the same. I have also looked at the ranking log between both and they look to be exactly the same.

    Any ideas on what I should look at to fix this discrepancy? Thanks.

    #44987

    Frank Grossmann
    Participant

    It is difficult to say why there is this discrepancy. Are you sure that the QuantTrader.ini files are the same? I would need to check this. If you want, then please send me the two QuantTrader.ini files by email to fpgrossmann@gmail.com

    #45138

    Charlie Moore
    Participant

    Problem solved. Thanks Frank.

    I had inadvertently set the max allocation for one component of the strategy. There is a feature in the portfolio manager that lets you set various values for components of your portfolio, ie max allocation.

Viewing 15 posts - 76 through 90 (of 104 total)

You must be logged in to reply to this topic.